Поддержка услуг » База знаний » Linux Server » Ошибка установки: check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM
 Ошибка установки: check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM
Решение Почему модули не устанавливаются, а пишет:

Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM /*!40101 DEFAULT CHARACTER SET cp1251 COLLATE cp1251_general_ci */' at line 7 in file /var/www/vhosts/ofby.in/httpdocs/dp_ultimate_install.php on line 46

Ответ:

Версия MySql выше Замените последнею строчку TYPE=MyISAM и т.д. На:
) ENGINE=MyISAM /*!40101 DEFAULT CHARACTER SET " . COLLATE . " COLLATE " . COLLATE . "_general_ci */";

Почему когда хочу скачать файл на DLE У меня пишет:

Warning: date(): It is not safe to rely on the system's timezone settings

Ответ:

Эта ошибка возникает на PHP 5.3. Исправить можно следующим образом:

Открываете на редактирование файл /etc/php.ini
Находите в нём закомментированную строчку
;date.timezone =
Снимаете комментарий и пишите туда значение часового пояса по умолчанию, например "Europe/Moscow". Часто в самом сообщении вы можете увидеть рекомендованное значение, которое нужно подставить в вашем случае
Не забудьте перезапустить веб-сервер, чтобы перечитались настройки PHP.

Разумеется вы можете установить это значение не только в php.ini, но и в настройках сайта.
в.htaccess
добавлением строки в скрипт:
Код:
date_default_vtimezone_set('America/Los_Angeles');


Подробности статьи
Cтатья №:83
Создано:24 Dec 2011 11:19 AM

 Этот ответ мне помог  Этот ответ мне не помог

 Назад
 Войти [Пароль утерян] 
Электронная почта:
Пароль:
Запомнить:
 
 Поиск
 Свойства статьи
Главная | Регистрация | Отправить заявку | База знаний | Загрузки
Язык:

© HiTex Technologies. 2009-2018